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About Adobe PDF forms

An Adobe PDF form is an electronic-based document that can collect data from a user and 
then send that data via email or the web. A PDF form can contain static or interactive 
form fields; interactive form fields let the user fill in the form using his or her computer, 
while static form fields must be printed and filled in by hand. Users who fill in a PDF 
form that contains interactive form fields using Adobe Acrobat Professional or Adobe 
Acrobat Standard can save their form data along with the PDF form; Adobe Reader users 
can save only a blank copy of the PDF form, unless the form author added special usage 
rights to the PDF form.

It's easy to create electronic PDF forms using Adobe Designer or Adobe Acrobat 
Professional. You can design and create an entirely new form, or you can quickly convert 
your existing paper and electronic forms to PDF and then add PDF form fields.

There are three types of Adobe PDF forms: 

●     Fill-and-print PDF forms are typically digital presentations of paper forms. Fill-and-print 
forms may contain interactive form fields or static form fields; either way, the user must 
manually deliver the form, such as via postal mail or fax machine.

●     Submit-by-email PDF forms contain a button that either extracts the form data from the 
PDF form and attaches that data to an email message or attaches the filled-in PDF form to 
an email message.

●     Submit on-line PDF forms contain a button that sends the form data to an online 
repository, such as a database. 

Related Subtopics:

Elements of an Adobe Acrobat PDF form
Guidelines for creating a new form in Adobe Acrobat Professional



 

Elements of an Adobe Acrobat PDF form

A PDF form created by Acrobat Professional can contain the following form elements:

Button

Can specify an action, such as opening a file, playing a sound, or submitting data to a web 
server.

Check boxes

Present a group of choices from which you can typically select one or more items.

Combo box

Presents a list of items in a pop-up menu for you to choose from or lets you enter your 
own values.

Digital signature field

Lets you electronically sign a PDF document with a digital signature.

Document Message Bar

Displays information about the PDF form and can display tools and options.

List box

Displays an entire list of options that you can scroll through and from which you may be 
able to select more than one item. 

Radio buttons

Present a group of choices from which you can typically select only one item.

Text field

Lets you fill in text such as name, address, and phone number. 

Adobe Acrobat PDF form A. Combo box B. Digital signature field C. Text boxes D. Forms 
Document Message Bar E. Check boxes F. Radio buttons G. List box H. Buttons



 

Guidelines for creating a new form in Adobe Acrobat 
Professional

To design a form from scratch, follow these general steps:

●     Define the form data you need to collect. Your data requirements determine the types of 
form fields to add to the form.

●     Design the form based on usability and visual appeal. Study examples of related forms, 
and sketch out the form on paper.

●     Determine the size of the form. Make sure that the page size you pick works well on a 
typical computer screen, 800 x 600 resolution. If your form will be printed, you may want 
to break it up into multiple pages. 

●     Lay out the static parts of the form, such as text, rectangles, text labels, and images, in an 
application such as Adobe Illustrator, Adobe InDesign, or Microsoft Word. (Alternatively, 
you can create your entire form in Adobe Designer, which lets you lay out static parts in 
addition to interactive and dynamic form elements. See Using Adobe Designer to create 
forms (Windows).)

●     Convert the document to PDF and add the form fields in Acrobat Professional. (For the 
most feature-rich form creation tools, use Adobe Designer (Windows only) instead. See 
Using Adobe Designer to create forms (Windows).)

 To make sure that your form appears the same way to viewers as it does on your 
monitor, choose web-safe RGB colors and embed fonts when you create the PDF file.



 

Setting Forms preferences 

To control various aspects of your interaction with form fields, use the Forms preferences. 

Note: These preferences aren't saved with a PDF form. The Forms preferences affect only 
how Acrobat handles forms that you open.

To set Forms preferences:

1.  Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS), and select 
Forms on the left.

2.  To set the General forms preferences, select any of the following:
●     To automatically perform all field calculations upon user entry, select Automatically 

Calculate Field Values.
●     To display which form field currently has the focus, select Show Focus Rectangle.
●     To retain forms data in the Internet browser, select Keep Forms Data Temporarily 

Available On Disk.
●     To display a plus sign (+) indicating when text fields exceed the bounds specified when 

the fields were created, select Show Text Field Overflow Indicator.
●     To hide the forms document message bar by default whenever a PDF form is opened in 

Adobe Reader, select that option.
●     To display the appearance of a form field when creating or editing forms, select Show 

Field Preview When Creating Or Editing Form Fields.
3.  To set the Highlight Color forms preferences, do any of the following:
●     To display a black outline around a form field when you place the pointer over that form 

field, select Show Border Hover Color For Fields.
●     If you want to change the color that appears in the background of all form fields when you 

select Highlight Fields in a PDF form's Document Message Bar, click the Fields Highlight 
Color button to select a color.

●     To display a particular color border around form fields that the form creator has made 
required, click the button next to Required Fields Highlight Color, and select a color. The 
color appears in required form fields only after you attempt to submit the form.

For information on using the Auto-Complete preferences, see Completing fields 
automatically.



 

Using Adobe Designer to create forms (Windows)

Adobe Designer is an application that comes with Adobe Acrobat Professional for 
Windows and can also be purchased separately. Designer lets you lay out a form from 
scratch, use a form template, or create a fillable and interactive form based on a 
nonfillable form. More advanced features in Designer let you use scripting objects, 
integrate a form with a data source, and create dynamic forms. Users can fill in a PDF 
form created with Adobe Designer if they have Adobe Acrobat Standard 7.0, Adobe 
Acrobat Professional 7.0, or Adobe Reader 7.0.

Note: PDF form fields that were created in Acrobat Professional can be modified in 
Designer, but PDF form fields that were created in Designer can't be modified in Acrobat 
Professional.

Related Subtopics:

About Adobe Designer (Windows)
Starting Adobe Designer (Windows)



 

About Adobe Designer (Windows)

Adobe Designer simplifies the creation of form designs for deployment as Adobe PDF or 
HTML forms. Using Designer, you can drag images and form objects, such as list boxes, 
drop-down lists, and buttons, onto a blank form. You can design a form, define its logic, 
modify it to match paper counterparts or meet strict legislative requirements, and then 
preview and test the form using Designer before deploying it. 

Form authors can also use Designer to build and maintain data-capture solutions that read 
from, validate against, and update corporate data sources. With Designer, you can 
integrate PDF forms into existing workflows by binding forms to XML schemas, XML 
sample data files, databases, and web services.



 

Starting Adobe Designer (Windows)

You can start the Adobe Designer application from within Adobe Acrobat Professional 
while initiating a forms-related task to perform in Designer or start Designer as you would 
any other stand-alone application on your computer. (For complete information on using 
Adobe Designer, choose Help > Adobe Designer Help in Adobe Designer.)

Note: Acrobat comments and file attachments in a PDF document aren't included in the 
PDF document copy that is opened in Designer.

To start Designer outside Acrobat:

Click the Windows Start button, and choose either All Programs > Adobe Designer or 
Programs > Adobe Designer 7.0.

 You can also start Designer while initiating a form-related task for a particular PDF 
document, such as converting a static form to an interactive form. Just choose the 
command for the task from the Form Tasks menu in the Tasks toolbar or the Advanced > 
Forms submenu.



 

Making a form fillable

You can add interactive form fields to a PDF document by using the extensive form tools 
in Adobe Designer (Windows) or the basic form tools in Acrobat Professional. If you 
want the most feature-rich form creation tools, have more advanced form needs, or have 
forms critical to your business, use Adobe Designer. (See Starting Adobe Designer 
(Windows).)

To start Designer using Acrobat and edit a PDF document:

1.  Open the PDF document in Acrobat.
2.  Choose Advanced > Forms > Open Form In Adobe Designer.

Related Subtopics:

Creating PDF forms from existing paper forms



 

Creating PDF forms from existing paper forms

Creating an Adobe PDF form from an existing form lets you maintain your organization's 
corporate identity and branding while saving you the effort of re-creating the form. To use 
an existing paper form, you can scan the paper form directly into Acrobat or you can scan 
the paper form and convert it to PDF using another application (see Creating Adobe PDF 
files from other applications). Once your form is converted, you can either use Adobe 
Designer or the forms tools in Acrobat to make the static form fields interactive.

To start Designer using Acrobat and create an interactive copy of a static PDF form:

1.  Open the static PDF form in Acrobat.
2.  Choose Make Form Fillable from the Form Tasks pop-up menu in the Tasks toolbar. If 

your PDF form contains unsaved changes, click Save in the Adobe Acrobat dialog box. 
3.  Click OK.
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Creating forms from scratch

Adobe Designer is a client-based point-and-click graphical form design tool that 
simplifies the creation of form designs for deployment as Adobe PDF or HTML forms. 
Designer lets you create a new blank form or create a new form from a template. You also 
have the option to explore sample forms. Using Designer, form authors can drag and drop 
images and other objects, such as list boxes, drop-down lists, and command buttons, onto 
their forms. They can design a form, define its logic, modify it to match paper 
counterparts or meet strict legislative requirements, and then preview the form before 
deploying it. 

Acrobat also offers several features that simplify the process of putting together an entire 
form but has less form-authoring features and abilities than Designer. With Acrobat you 
can precisely place and align form fields on a page using grids, guides, and rulers. For 
details, see Using layout tools.

To start Designer using Acrobat and create a new blank form: 

1.  Choose Create New Form from the Forms pop-up menu in the Tasks toolbar.
2.  Click OK in the Create New Form dialog box.
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Creating and editing form fields

If you've already created a PDF form with the Acrobat form tools, but want to take 
advantage of the extensive form tools in Designer, you can use Designer to import the 
PDF form or you can use the Edit Fillable Form command in Acrobat to start the import 
process.

The more limited form features in Acrobat let you create a form field by choosing one of 
the form tools, defining the area of the field on the Adobe PDF document page, and 
naming the field. For each field type, you can set a variety of options through the form 
field Properties dialog box. (SeeSetting Forms preferences.)

Note: Adobe Designer can edit form fields that you created with Acrobat, but Acrobat 
can't edit form fields that you created with Designer.

To start Designer using Acrobat and edit an interactive PDF form:

1.  Open the interactive PDF form in Acrobat.
2.  Choose Edit Fillable Form from the Forms pop-up menu in the Tasks toolbar.
3.  Do one of the following, according to the dialog box that appears:
●     In the Edit Fillable Form dialog box, select Adobe Designer and click OK. If your PDF 

form contains unsaved changes, click Save in the Adobe Acrobat dialog box. Click OK in 
the Edit Form In Adobe Designer dialog box. A copy of your form opens in Designer.

●     In the Edit XML Form In Adobe Designer dialog box, click OK. If your PDF form 
contains unsaved changes, you first need to click Save in the Adobe Acrobat dialog box.

For more information on using Designer, see Designer Help.

To create a form field in Acrobat:

1.  Choose Tools > Advanced Editing > Show Forms Toolbar.
2.  On the Forms toolbar, select a forms tool.
3.  Do one of the following:
●     Drag the cross-hair pointer to create a form field of the required size.
●     Double-click the page to create a form field using the default size.

Note: You cannot create a form field on top of a comment.

4.  In the [form field name] Properties dialog box, set the form field's property options, and 
then click Close. (For more information on setting the form field properties, see Setting 
Acrobat form field properties.)

 To add form fields to a PDF document's tags tree at the same time that you create 
the form fields in Acrobat, make sure that Tag Annotations is selected in the Options 
menu of the Tags tab. Select the item in the tags tree that should be the parent of the form 
field you are about to create, and create the form field. (To add existing form fields to the 
tags tree, see Advanced Tools for Correcting Tagging Errors.)

Related Subtopics:

Editing or deleting form fields in Acrobat
Selecting form fields
Duplicating form fields
Creating multiple form fields with Acrobat
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Editing or deleting form fields in Acrobat

You can edit the properties of, resize, or delete a single form field or multiple form fields 
simultaneously.

To resize one or more form fields:

1.  Select the form fields you want to resize. (See Selecting form fields.)
2.  Do one of the following:
●     To resize the fields by dragging, select the form tool that was used to create the form field, 

and then drag any border handle on the field. Press Shift to maintain the current aspect 
ratio of the form field.

●     To resize the fields by 1 pixel, press Ctrl+Arrow key (Windows) or Command+Arrow key 
(Mac OS); to resize the fields by 10 pixels, press Ctrl+Shift+Arrow key (Windows) or 
Command+Shift+Arrow key (Mac OS).

●     To resize all form fields in the form to the width, height, or both dimensions of a 
particular form field, make sure that all form fields are selected; then right-click 
(Windows) or Control-click (Mac  OS) over the form field that has the dimension you 
want and choose Height, Width, or Both from the Size menu. 

To delete one or more form fields:

1.  Select the form fields you want to delete. (See Selecting form fields.)
2.  Press Delete, or choose Edit > Delete.

To modify form field properties:

1.  Select the form fields you want to edit. (See Selecting form fields.)
2.  Open the Properties dialog box using one of the following methods:
●     Double-click a selected form field. 
●     Click the More button on the Properties toolbar.

 The Properties toolbar contains only those settings that are most commonly 
changed. To view the complete set of properties in the Properties dialog box, click the 
More button.

3.  Click the General tab, and specify the following properties:
●     Enter a name, tool tip text, and other general properties. (For information on the Tooltip 

option, see Making Adobe PDF forms accessible.)
●     Select the Read Only option to prevent the field from being modified by the user.

 To avoid accidental changes to the form field, select Locked in the lower left 
corner of the Properties dialog box.

4.  Click the Appearance tab, and then specify the appearance properties. The appearance 
properties determine how the form field looks on the page. Remember, if you select a 
background color, you won't be able to see through to any images behind the form field.

5.  Click the Actions tab, and specify any actions that you want to associate with the form 
field, such as jumping to a specific page or playing a media clip. (See Using actions for 
special effects.)

Specify the remaining properties for your form field type, and click Close. For details, see 
Setting Acrobat form field properties.
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Selecting form fields

You can select multiple form fields and then modify the appearance, size, and location of 
all of them at once. When you select multiple form fields, the last one you select is 
highlighted in red, and is designated as the anchor. The other form fields are highlighted 
in blue. If you use a marquee to select form fields, the form field that was created first is 
designated as the anchor. Any size or alignment changes you make to the selected form 
fields are made relative to the anchor form field.

If you select form fields that have different property values, some options in the Properties 
dialog box are not available. Changes to the available options are applied to all selected 
form fields. For example, if you select two text fields and one text field has Arial specified 
as the default font, and the other has Verdana, when you change the default font to Times 
New Roman, the font change is applied to both text fields.

To select form fields:

1.  Do one of the following:
●     In the Forms toolbar, select the forms tool you used to create the form field that you want 

to change.
●     Choose Tools > Advanced Editing > Select Object tool.
2.  To select a single form field, click it. To select multiple form fields, do one of the 

following:
●     Ctrl-click (Windows) or Option-click (Mac OS) each form field.
●     Ctrl-drag (Windows) or Option-drag (Mac OS) a selection marquee around the form 

fields. If you are using a forms tool, only form fields of the same type are selected; for 
example, if the Button tool is selected, only button form fields are selected. If you are 
using the Select Object tool, all types of form fields within the marquee are selected.

●     To add a range of form fields to a selection, click a form field, and then Shift-click another 
form field. All form fields between the two form fields are selected.

●     Choose Edit > Select All.

To remove a form field from a selection, Ctrl-click (Windows) or Option-click (Mac OS) 
inside the form field. To deselect an entire selection, click outside a form field. If you 
remove the anchor form field from a selection, the form field located in the top left 
position of the selection becomes the new anchor form field.



 

Duplicating form fields

You can duplicate form fields on the same page or across pages. When you duplicate a 
form field, users can fill in one form field and have that information appear in all the form 
fields with the same name, no matter what page they are on. The copied form fields can be 
given different appearances, but they must have the same name and actions. Changing an 
action in a form field changes the action for all form fields with the same name, with the 
exception of mouse actions. Mouse actions are confined to a single field.

 If you want to quickly add form fields that don't behave as duplicated fields when a 
user enters information, duplicate or copy the form fields, and then change each form 
field's name. Changes made to the original duplicated form field affect only those form 
fields with the same name. 

To duplicate a form field on the same page:

1.  On the Forms toolbar, select the tool used to create the form field.
2.  Select the form field, and do one of the following:
●     Ctrl-drag (Windows) or Option-drag (Mac OS) the form field to the new position. To 

constrain the movement horizontally or vertically, press Shift while continuing to drag the 
form field.

●     To duplicate the form field to the center of the current view, choose Edit > Copy, and then 
choose Edit > Paste.

To duplicate a form field across pages:

1.  On the Forms toolbar, select the tool used to create the form field.
2.  Select the form field, and choose Advanced > Forms > Fields > Duplicate.
3.  In the Duplicate Field dialog box, do one of the following, and then click OK:
●     Select All to duplicate the form field across all the pages in the form.
●     Type a page range to duplicate the form field across the specified page range.

The form field is duplicated and placed in the location (x and y coordinates) of the 
selected form field across the specified page range.



 

Creating multiple form fields with Acrobat

You can quickly create multiple form fields that have the same field types or even 
different form field types. You set up the first row or column of form fields, which act as 
the anchor row or column. Then you select the number of rows and columns, the size of 
the fields, and the overall position of all the fields on the page. The new fields are named 
according to the anchor name and appended with a number. For example, you might 
create an anchor field and assign the field name Title. You then create two copies of the 
Title form field, the two new form fields would be renamed Title.0, and Title.0.0. All new 
fields will be created sequentially, using standard array format.

To create multiple copies of form fields: 

1.  Using a form field tool, create one or more fields.
2.  Ctrl-drag (Windows) or Option-drag (Mac OS) a selection marquee around the form fields.
3.  Choose Advanced > Forms > Fields > Create Multiple Copies.
4.  In the Create Multiple Copies Of Fields dialog box, do the following, and then click OK:
●     Specify the number of fields down and across.
●     Specify the overall size for all the fields.
●     Use the Up, Down, Left, and Right buttons to position the fields where you want them to 

appear.
●     Click Preview to preview the results.



 

Setting Acrobat form field properties

You can set a variety of properties for an Acrobat form field, depending on the form field 
type. For example, the combo box and text form fields include format, validation, and 
calculation properties; however, these settings are not available for a check box form field. 

To save time when creating form fields, you can define default properties for a specific 
form field type, which you can then use as a template when you add another form field of 
the same type. For example, you can create a check box, specify all the properties, and 
save the properties as the default values for all check boxes. The next check box you add 
to the form will have the same property values.

 To make a form field display helpful text, such as instructions or the form field's 
text label, when the user places the pointer over the form field, just type the text in the 
Tooltip box in the Text Field Properties window. The Tooltip text is also read by screen 
readers. (See Making Adobe PDF forms accessible.)

To set default properties for a form field type:

1.  To select the form field, do one of the following:
●     Select the forms tool you used to create the form field that you want to change.
●     Choose Tools > Advanced Editing > Select Object tool.
2.  Open the form field properties dialog box, and specify the settings.
3.  Right-click (Windows) or Control-click (Mac OS) the form field, and then select Use 

Current Properties As New Defaults. (Double-click on the page to create a form field 
using the default properties settings for that form field type.)

Related Subtopics:

Defining the tabbing order of form fields
Changing Acrobat check box properties
Changing combo box properties
Changing text field properties
Format options
Validation options
Calculation options
Changing list box properties
Changing radio button properties
Changing digital signature field properties



 

Defining the tabbing order of form fields

If a PDF document isn't tagged and doesn't have a specified tab order, the order in which 
the form fields were created determines their tabbing order. If a PDF document is tagged, 
the document structure determines the form fields' tabbing order unless the user has 
deselected the Tab Order option in the Accessibility preferences. (See Setting accessibility 
preferences.)

You can use the Tab Order options in the Page Properties to set the tab of form fields by 
the row order, column order, or document structure. (See Defining the tabbing order.) This 
method is useful only if the form fields are organized in rows or columns, or if the form 
fields are tagged. Ideally, you should use Adobe Designer for its additional options and 
control for setting the tabbing order. (See Using Adobe Designer to create forms 
(Windows).) If you want to manually customize the tab order with Acrobat, you can use 
the Set Tab Order command. 

To set the tabbing order of form fields:

1.  Choose Advanced > Forms > Fields > Set Tab Order. Each form field displays a unique 
number that represents its tabbing order.

Note: You can choose this command only if the tab order property in the Page Properties 
is set to Unspecified.

2.  To change a form field's tab number, click the field.
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Changing Acrobat check box properties

Check boxes are the simplest form fields and they share the same General, Appearance, 
and Actions tabs as the other form field types. The Options tab contains a few simple 
properties that you can change to customize your check box form field.

Note: The size of the check inside the check box is determined by the size of the font you 
specify on the Appearance tab.

To change check box properties:

1.  In the Check Box Properties dialog box, click the Options tab, and do any of the following 
options:

●     Select a check box style and whether you want the check box to be checked by default.
●     Enter an export value to represent the chosen item if it is exported to a CGI application. 

(See Defining CGI export values.)
2.  Click Close to apply the selected property options.



 

Changing combo box properties

The Options tab in the Combo Box Properties dialog box specifies a list of items and 
export values for a user to select from, and how the items are managed. You can also 
allow the user to enter a custom value directly into the combo box.

To change combo box properties:

1.  In the Combo Box Properties dialog box, click the Options tab.
2.  In the Item field, enter the first item in the list.
3.  In the Export Value field, enter a value that represents the chosen item if it is exported 

(optional) to a CGI application. If a value is not entered, the item name is used as the 
exported value. (See Defining CGI export values.) 

4.  Click Add.
5.  Repeat steps 2 through 4 to add items to the list.
6.  Use the Up and Down buttons to rearrange the items in the list, or the Delete button to 

remove items from the list.

Note: The highlighted item in the Item List box appears as the default selected item in the 
combo box field. To change the default item, highlight another item from the list.

7.  Select any of the following options: 
●     Select Sort Items to sort the Item List numerically and alphabetically. A numeric sort (if 

applicable) is performed before an alphabetical sort.
●     Select Allow User To Enter Custom Text to allow the user to enter a value other than the 

ones in the list.
●     Select Check Spelling to spell-check values entered by the user. This option does not 

apply to items selected from the list of available entries.
●     Select Commit Selected Value Immediately to save the value as soon as the user selects it. 

If this option is not selected, the value is saved only when the user tabs out of the current 
field or clicks another form field.

8.  Click the Format tab, and choose a category type from the list. This specifies the type of 
data (numeric, date, time, and so on) the user can enter. (For details, see Format options.)

9.  Click the Validate tab to run a custom validation script to establish that the text entered by 
the user is valid. (For details, see Validation options.)

10.  Click the Calculate tab, and select the options if you want to perform mathematical 
operations. (For details, see Calculation options.)

11.  Click Close.



 

Changing text field properties

Text fields can be set up to accept user input, to display text strings, and to allow multiple 
lines of text. You can also set a wide variety of text field properties, such as limiting the 
number of characters a user can type into the field, and displaying lines between each 
character inside the text field. 

Text fields with and without the Comb property A. Four text fields with a border color, using the 
Comb property B. Text field without the Comb property

Note: Some property settings are dependent on others. For example, you cannot check the 
spelling of a password field or a field used for file selection. These options appear 
unavailable. You must deselect the check spelling option before you can select the 
password or field used for file selection options.

To change text field properties:

1.  In the Text Field Properties dialog box, click the Options tab, and then do any of the 
following:

●     Select the text field alignment from the Alignment menu. This sets the alignment of text 
within the text box; it does not align the text box itself.

●     Type the default value text for the text field. You can leave the text box empty. You can 
also use the General tab to make the text box Read Only. (See Creating and editing form 
fields.

●     Select Multi-line to allow for more than a single-line entry in the text field.
●     Select Scroll Long Text to compensate for text that extends beyond the boundaries of the 

text field.
●     Select Allow Rich Text Formatting to allow users to apply styling information to the text, 

such as bold or italic. This might be useful in certain text fields where such styling 
information is important to the meaning of the text, such as an essay.

●     Select Limit Of Characters to set a limit to the number of characters that can be entered in 
the field.

Note: If you entered a default value, that value is clipped to this limit.

●     Select Password to have the text field display all entered text as a series of asterisks.
●     Select Field Is Used for File Selection to allow a file path to be the field's value. The file is 

submitted along with the form. (You must select Scroll Long Text, and deselect all other 
options for this option to be available.)

●     Select Check Spelling to spell check the text entered by the user.
●     Select Comb Of Characters, and enter a value to create a text field that spreads characters 

evenly across the width of the text field. If a border color is also used, border lines 
separate each character within a single text field.

2.  Click the Format tab, and choose a category type from the list. This specifies the type of 
data (numeric, date, time, and so on) the user can enter. (For details, see Format options.)

3.  Click the Validate tab to run a custom validation script to establish that the text entered by 
the user is valid. (For details, see Validation options.)

4.  Click the Calculate tab, and select the desired options for performing mathematical 
operations. (For details, see Calculation options.)

5.  Click Close.



 

Format options

In the Select Format Category menu, you can choose the format of data entered in text and 
combo box form fields, such as numbers, percentages, dates, and times.

In the Special category, you can select the format for ZIP codes, telephone numbers, and 
social security numbers. You can also use the Arbitrary Mask option to specify the types 
of characters the user can enter in any given position, and how the data displays in the 
field. The following characters are used to specify the types of characters that can be 
entered:

●     A--Accepts only letters (A-Z, a-z).
●     X--Accepts spaces and most printable characters, including all characters available on a 

standard keyboard and ANSI characters in the ranges of: 32-126 and 128-255.
●     O--The letter "O" accepts alphanumeric characters (A-Z, a-z, and 0-9).
●     9--Accepts only numeric characters (0-9).

For example, a mask setting of AAA--p#999 accepts the input BOE--p#767. A mask 
setting of OOOOO@XXX accepts the input vad12@3Up.

Arbitrary Mask option

The Custom format category lets you create new data formats and keystroke validation 
scripts with your own custom JavaScripts. For example, you can define a new currency 
format or limit the entry to specific keystroke characters. To access the Acrobat JavaScript 
Scripting Reference, go to http://partners.adobe.com/links/acrobat (English only) on the 
Adobe website.

Note: Select None from the menu if you do not want to specify any special form-field 
formatting.



 

Validation options

Use validation properties to restrict entries to specified ranges, values, or characters. This 
ensures that users enter the appropriate data for a specified form field. You can also use 
custom JavaScripts to define other types of validation, such as allowing only alphabetic 
entries in a form field. To access the Acrobat JavaScript Scripting Reference, go to http://
partners.adobe.com/links/acrobat (English only) on the Adobe website.

You can select from the following validation options:

●     To turn off validation, select Field Value Is Not Validated.
●     To specify a numeric range for form fields using number or percentage formats, select 

Field Value Is In Range. 
●     To run a JavaScript for custom validation, select Run Custom Validation Script.



 

Calculation options

The calculation options let you perform mathematical operations on existing form-field 
entries and display the result. You can use the common operations predefined in the 
Calculate Properties dialog box, or you can define more complex operations using a 
custom JavaScript. To access the Acrobat JavaScript Scripting Reference, go to http://
partners.adobe.com/links/acrobat (English only) on the Adobe website.

When you define two or more calculations in a form, the order in which they are carried 
out is the order in which you defined the calculations. In some cases, you may need to 
modify the calculation order to obtain correct results. For example, if you wanted to use 
the result obtained from calculating two form fields to calculate the value of a third form 
field, the first two form fields must be calculated together first to obtain the correct final 
results. Acrobat Professional automatically performs all assigned field calculations when 
you are creating and testing your form fields. For convenience, you can turn off automatic 
calculation while you work. (See Setting Forms preferences.) You can select from the 
following calculation options:

●     To define the form field without calculation properties, select Value Is Not Calculated.
●     To perform a simple calculation based on the values of two or more fields, select Value Is 

The __ of the following fields, and choose an operation from the menu.

Note: Simple calculations are available only for form fields that use number or percentage 
formats. (See Format options.)

●     To specify calculation expressions in a spreadsheet-like format, such as Sum=Field1
+Field2, select Simplified Field Notation. 

●     To use JavaScript for custom calculations, choose Custom Calculation Script, and enter 
the JavaScript code.

To specify the calculation order of form fields:

1.  Choose Advanced > Forms > Set Field Calculation Order. The Calculate Fields dialog box 
displays all calculable fields in your form and the order in which the calculations are 
performed.

2.  To change the field calculation order, select the field from the list, and then select the Up 
or Down button.

3.  Click OK.



 

Changing list box properties

The properties for a list box form field are similar to the properties for a combo box. 
However, the Selection Change tab allows you to assign a JavaScript action that is 
executed any time a user selects or switches between items in the list. For example, you 
can play a sound or display an image as the user changes selections.

To change list box properties:

1.  In the List Box Properties dialog box, click the Options tab.
2.  Enter a name in the Item field.
3.  In the Export Value field, enter a number value that represents the chosen item if it is 

exported (optional) to a CGI application. If a value is not entered, the item name is used as 
the exported value. (See Defining CGI export values.) 

4.  Click Add.

Note: The highlighted item in the Item List box appears as the default selected item in the 
list box field. To change the default item, select another item from the list. 

5.  Repeat steps 2 through 4 to add items to the list.
6.  Use the Up and Down buttons to rearrange the items in the list, or the Delete button to 

remove items from the list.
7.  Do any of the following:
●     Select Sort Items to sort the Item List numerically and alphabetically. A numeric sort (if 

applicable) is performed before an alphabetical sort.

Note: If you select Sort Items, the Up and Down buttons are disabled.

●     Select Multiple Selection to allow the user to select more than one item in the list.
●     Select Commit Selected Value Immediately to save the value as soon as the user selects it. 

This option is not available if the Multiple Selection option is selected.
8.  Click the Selection Change tab, and then select Execute This Script if you want a 

JavaScript to start when the user changes the list selection. Click Edit, and then copy and 
paste a predefined script or enter the script directly. To access the Acrobat JavaScript 
Scripting Reference, go to http://partners.adobe.com/links/acrobat (English only) on the 
Adobe website.

9.  Click Close.



 

Changing radio button properties

To create related radio buttons, each radio button field must have the same Name property 
as the related radio buttons, and each must have a unique export value. The export value is 
the information that distinguishes and identifies the radio button and can be used by a CGI 
application on a web server. (See Defining CGI export values.)

To change radio button properties:

1.  In the Radio Button Properties dialog box, click the Options tab, and then do any of the 
following:

●     Select a style for the radio button. Circle is the default.
●     Enter an export value to identify the radio button and differentiate it from other radio 

buttons that share the same Name value.
●     Select whether or not you want the radio button checked by default.
●     Select whether or not you want radio buttons with the same name and value selected in 

unison. For example, if the user selects a radio button that has the same field name and 
export value as another, both radio buttons are selected.

2.  Click Close.



 

Changing digital signature field properties

When you create a digital signature form field, you can specify an action to be executed 
when the form field is signed. (See Signing Adobe PDF documents.)

To change digital signature field properties:

1.  In the Digital Signature Field Properties dialog box, click the Signed tab, and then do one 
of the following:

●     Select Nothing Happens When Signed. This is the default.
●     Select Mark As Read-Only to lock the named field when the form field is signed. If you 

choose Just These Fields or All Fields Except These, click Pick. In the Field Selection 
dialog box, select one or several fields, and then click OK.

●     Select This Script Executes When Field Is Signed to execute the JavaScript in the dialog 
box. Click Edit to edit an existing JavaScript or to create a new JavaScript action.

2.  Click Close.
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Positioning form fields

You can position form fields in a PDF file manually; by aligning, centering, or 
distributing multiple fields relative to one other; or by using a grid for precise positioning.

Related Subtopics:

Moving form fields manually
Aligning, centering, and distributing form fields
Positioning form fields with grids



 

Moving form fields manually

You can manually position one or more form fields in a PDF file by dragging, by using 
keyboard keys, or with the Cut and Paste commands.

To move one or more form fields:

1.  Select the form fields. 
2.  Do one of the following:
●     Approximately position the form field by moving the pointer inside the selected form 

field, and drag the field to the new location. To constrain movement to a horizontal or 
vertical direction, begin dragging, and then press Shift while continuing to drag the 
selection.

●     Precisely position the form field using the arrow keys to nudge the selected form field into 
position.

●     Exactly relocate the form field to the center of the current page by choosing Edit > Cut, 
navigate to the desired location, and then choose Edit > Paste. 

Note: Fields are placed in the center of the page only the first time they are pasted. 
Additional pasted fields are staggered below and to the right of the previously pasted field.



 

Aligning, centering, and distributing form fields

You can quickly position form fields by aligning them relative to one another, centering 
them relative to the page, or distributing them relative to one another.

To align form fields:

1.  On the Forms toolbar, select the tool used to create the form field.
2.  Press Shift and select the form fields that you want to align. You must select a minimum 

of two form fields.
3.  Right-click (Windows) or Control-click (Mac  OS) the field that is to remain stationary, 

and then choose a command from the Align menu:
●     Left, Right, Top, or Bottom aligns all form fields with the respective border of the anchor 

form field.
●     Vertically aligns all form fields along the vertical axis of the anchor form field.
●     Horizontally aligns all form fields along the horizontal axis of the anchor form field.

To center form fields:

1.  In the Forms toolbar, select the tool used to create the form field.
2.  Press Shift and select the form fields that you want to center.
3.  Right-click (Windows) or Control-click (Mac  OS), and choose a command from the 

Center menu:
●     Vertically centers the form fields with respect to the page's vertical dimension.
●     Horizontally centers the form fields with respect to the page's horizontal dimension.
●     Both centers the form fields on the page.

To distribute form fields:

1.  On the Forms toolbar, select the tool used to create the form field.
2.  Press Shift and select the form fields that you want to distribute. You must select a 

minimum of three form fields.
3.  Right-click (Windows) or Control-click (Mac  OS) and choose one of the following 

commands from the Distribute menu:
●     Vertically distributes the intermediate form fields evenly between the topmost and 

bottommost form fields in the selection. This action disregards Snap To Grid.
●     Horizontally distributes the intermediate form fields evenly between the leftmost and 

rightmost form fields in the selection. This action disregards Snap To Grid.



 

Positioning form fields with grids

You can use grids to help position form fields at precise points on a page. The grid lines 
do not get printed. You can define the grid spacing, color, and position of a grid. You can 
also choose whether to have the boundaries of a form field snap to grid lines when you are 
editing the form field. (See Viewing grids.)
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Using templates to generate forms dynamically with 
Acrobat

You can define a page in your document as a template, which can then be used to 
dynamically generate a new form or duplicate PDF pages on the fly. In essence, you can 
build a form that dynamically creates another form. Templates allow the user to fill out as 
many form pages as needed. Additional pages (complete with new form fields) are 
spawned on the fly. To access the Acrobat JavaScript Scripting Reference, go to http://
partners.adobe.com/links/acrobat (English only) on the Adobe website. 

Note: If you are generating a form by importing data from a database, you can spawn as 
many pages as needed to contain different quantities of data.

Important: Template functionality is not supported in Adobe Reader unless additional 
usage rights were added with a server extension. (See If you want to create documents that 
extend features to Adobe Reader users.) Therefore, if you create an Acrobat application 
that uses template functionality, a user who has access only to Adobe Reader won't be 
able to use your application.

To define a template:

1.  Navigate to the page you want to use as a template, and choose Advanced > Forms > Page 
Templates.

2.  Enter a name for the template, and click Add.
3.  Click Close to define the template.

To edit a template:

1.  Choose Advanced > Forms > Page Templates.
2.  Select the desired template in the list, and do one of the following:
●     To hide the selected template page, click the eye icon to the left of the template name. To 

show the template, click the icon again. When you show a hidden template page, it 
appears appended to the end of the document. You cannot hide a template page if it is the 
only page in the document. 

●     To change the template contents to the currently displayed page, click Change.
●     To remove the selected template from the list, click Delete.
●     To display the selected template page, click Goto. You cannot use Goto to display a 

template that is hidden. 
3.  Click Close to accept the template changes.
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Creating buttons

Buttons are most commonly associated with forms, but you can add them to any 
document. Buttons can open a file, play a sound or movie clip, submit data to a web 
server, and much more. When deciding on how to initiate an action, remember that 
buttons offer the following capabilities that links and bookmarks do not:

●     A button can activate a series of actions, not just a single action.
●     A button can have alternate appearances, determined by mouse behavior when over the 

button.
●     A button can be easily copied across many pages.
●     Mouse actions can activate different button actions. For example, Mouse Down (a click), 

Mouse Up (releasing after a click), Mouse Enter (moving the pointer over the button), and 
Mouse Exit (moving the pointer away from the button) can all start a different action for 
the same button.

Related Subtopics:

Creating interactive buttons
Customizing button displays
Showing and hiding image buttons



 

Creating interactive buttons

Buttons are an easy, intuitive way to let users initiate an action in Adobe PDF documents. 
Buttons can have a combination of labels and icons to lead users through a series of 
actions or events by changing as the mouse is moved. For example, you can create buttons 
with "Play," "Pause," and "Stop" labels and appropriate icons. Then you can set actions 
for these buttons to play, pause, and stop a movie clip. You can select any combination of 
mouse behaviors for a button and specify any combination of actions for a mouse 
behavior.

Buttons on a sample PDF page

To add an interactive button:

1.  To select the Button tool , choose Tools > Advanced Editing > Forms > Button Tool.
2.  Drag the cross-hair pointer to create the button area.
3.  Click the General tab, and then specify a name, tool tip text, and other common properties.
4.  Click the Appearance tab, and then specify options to determine how the button will look 

on the page. Remember, if you select a background color, you won't be able to see through 
to any images behind the button. The text options affect the label you specify in the 
Options tab, not the button name in the General tab.

5.  Click the Options tab, and select options to determine how labels and icons appear on the 
button. (See Customizing button displays.)

6.  Click the Actions tab, and then specify options to determine what happens when the 
button is clicked, such as jumping to a different page or playing a media clip. (See Using 
actions for special effects.)

7.  Click Close.

 If you're creating a set of buttons, you may want to snap the object to grid lines or 
guides. (See Using layout tools.)

To edit a button:

Select the Button tool, and then do any of the following:

●     To edit the button's properties, double-click the button.
●     To change the button's appearance, click the button, and then specify options using the 

Properties toolbar. You can also change these appearance options in the Appearance tab of 
the Properties dialog box.

●     To align, center, or distribute the button with other form fields, or to resize or duplicate 
the button, right-click (Windows) or Control-click (Mac OS) the button, and then choose 
an option from the context menu. (See Editing or deleting form fields in Acrobat.)
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Customizing button displays

A button can have a label, an icon, or both. You can change how the button appears in each mouse state (Up, Down, and 
Rollover). For example, you could create a button that has a "Home" label until the pointer is moved over the button, 
when it might have a "Click to return to Home page" label. 

Button layouts A. Label only B. Icon only C. Icon top, label bottom D. Label top, icon bottom E. Icon left, label right F. Label 
left, icon right G. Label over icon

You can make button icons from any file format that Acrobat can display, including PDF, JPEG, GIF, and other image 
formats. For whichever format you select, the entire page is used, so if you want to use only a portion of a page as an 
icon, you need to crop the image or page before carrying out this procedure. The smallest allowable PDF page size is 1-
by-1 inch. If you want the icon to appear smaller than 1-by-1 inch, scale it to fit the size of the box drawn with the 
button tool. Clicking Advanced on the Options tab of the Button Properties dialog box lets you determine how a button 
icon is scaled to fit inside a button.

To specify button display properties:

1.  In the Advanced Editing toolbar, select the Button tool .
2.  Double-click an existing button, and then click the Options tab in the Button Properties dialog box.
3.  For Layout, choose the type of label display you want. (For information on scaling button icons, see the next procedure.)
4.  For Behavior, specify the display of the button when clicked:
●     None keeps the appearance of the button the same. 
●     Push lets you define different appearances for the Up, Down, and Rollover states of the mouse. Select an option under 

State, and then specify a label or icon option. Up determines what the button looks like when the mouse button isn't 
clicked. Down determines what the button looks like when the mouse is clicked on the button, but before it's released. 
Rollover determines what the button looks like when the pointer is held over the button. (See Showing and hiding image 
buttons.)

●     Outline highlights the button border.
●     Invert reverses the dark and light shades of the button.
5.  To define the label or icon that appears on the button, do the following:
●     If a label option is selected from the Layout menu, type the text in the Label box.
●     If an icon option is selected from the Layout menu, click Choose Icon, and then click Browse. Select the file type from 

the Objects of Type (Windows) or Show (Mac OS) menu, double-click the file name, and then click OK. (Click Clear to 
remove the selected icon.)

6.  Click Close to accept these display properties.

To scale and position button icons:

1.  On the Advanced Editing toolbar, select the Button tool , and then double-click the button. 
2.  Click the Options tab, select one of the icon options from the Layout menu, and then click Advanced.
3.  From the When to Scale menu, select one of the following options:
●     Always scales the icon as defined regardless of its size in relation to the button size.
●     Never preserves the icon's original size; the button border crops the icon if it doesn't fit. If Never is selected, scale 

options aren't available.
●     Icon Is Too Big scales the icon as defined only if it is larger than the button.
●     Icon Is Too Small scales the icon as defined only if it is smaller than the button.
4.  From the Scale menu, select whether or not to scale the icon proportionally. If the icon is scaled nonproportionally, it 

may be skewed.
5.  To make sure that either the top and bottom or left and right sides of the icon are flush against the button edges, select 

Fit To Bounds.
6.  To define where the icon is placed inside the button, drag the slider arrows. Icon placement is defined according to the 

percentage of space preserved between the icon and the left field boundary, and between the icon and the bottom field 
boundary. The default setting (50, 50) places the icon in the middle of a field. You can click Reset at any time to revert 
to the default placement setting.

7.  Click OK, and then click Close.



 

Showing and hiding image buttons

In some cases, you may want the button area to be invisible until the pointer moves over 
it. By alternately showing and hiding a button, you can create interesting visual effects in 
a document. For example, when you move a pointer over a city on a map, a detail map of 
the city could be displayed, and the detail map could disappear when the pointer moves 
away from the city.

Showing and hiding icons A. Pointer not over button area B. Pointer enters button area C. Pointer 
exits button area

To create a button that appears only during mouse rollover:

1.  Using the Button tool , drag across the area where you want the pop-up button to 
appear. For example, if the PDF file contains a map of France, drag across the area where 
you want a detailed map of Paris to pop up.

2.  Using the Button tool , double-click the button.
3.  Click the Options tab, and choose Icon Only from the Layout menu. 
4.  Choose Push from the Behavior menu, and then choose Rollover from the State list.
5.  Click Choose Icon, and then click Browse. Select the file type from the File Of Type 

(Windows) or Show (Mac OS) menu, navigate to the location of the image file, and then 
double-click the file. In this example, you would select a map of Paris. Click OK to accept 
the previewed image as the button.

6.  Click the Appearance tab. If needed, deselect Border Color and Fill Color, and then click 
Close.

7.  Select the Hand tool , and move the pointer across the button. The image field you 
defined appears as the pointer rolls over the button area and disappears when it exits.

 If you want the image to be larger than the rollover area, or if you want the image 
to be in a different location than the image button that pops up, use the Show/Hide A Field 
action. First, you specify an icon for the button that will be shown and hidden. Next, you 
create a second button that acts as a hot spot when the mouse rolls over it. You do not 
assign an icon for the appearance of the second button. Instead, you use the Actions tab to 
show the first button when the pointer enters the second button, and hide the first button 
when the pointer exits. (See Using actions for special effects.)
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Making Adobe PDF forms accessible

You can make your form fields accessible to vision- and motion-challenged users by 
adding tags to the PDF file and by properly structuring it. (See Making existing Adobe 
PDF documents accessible.) In addition, you can use the Tooltip form field property to 
provide the user with information about the field or to provide instructions; for example, 
using the Tooltip property's value, the screen reader could say "Your name." Without the 
Tooltip property, a screen reader simply names the type of form field. 

To add instructional information to a form field:

1.  Do one of the following to open the form field's Properties window:
●     Double-click a selected form field. 
●     Click the More button on the Properties toolbar.
2.  In the General tab, type instructional text into the Tooltip box.
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Making Adobe PDF forms web-ready

PDF forms can be useful for submitting and collecting information over the web. This is 
done by providing several button actions that perform functions similar to some HTML 
scripting macros. You must have a CGI application on the web server to collect and route 
the data to a database. Any existing CGI application that collects data from forms (in 
HTML, FDF, or XML format) can be used. (See http://partners.adobe.com/asn/acrobat/
forms.jsp.)

Before you make your forms web-ready, make sure that your form-field names match 
those set in the CGI application.

Important: CGI scripts must be built outside Acrobat, and their creation is not covered by 
the Adobe Acrobat product. 

Related Subtopics:

Creating Acrobat submit buttons
Creating Reset Form buttons
Creating Import Data buttons
Defining CGI export values



 

Creating Acrobat submit buttons 

Use the Submit A Form action to send form data to an email address or to a web server by 
specifying a Uniform Resource Locator (URL). You can also use the submit button to 
send other files back to a server or database. For example, you can attach scanned images 
or files to a form. The files are submitted along with the rest of the form data when you 
click the submit button.

 If your PDF form contains an email-based submit button, you can use the Initiate 
Data File Collection workflow to facilitate distributing the form to others. (See Collecting 
form data by email.)

To create a submit button:

1.  On the Forms toolbar, select the Button tool, and create a button. (See Creating interactive 
buttons.)

2.  Double-click the button to open the Button Properties dialog box.
3.  Click the Actions tab, and select Mouse Up from the Select Trigger menu.
4.  Select Submit a Form from the Select Action menu, and then click Add.
5.  In the Submit Form Selections dialog box, do one of the following in the Enter A URL 

For This Link box:
●     To send the form data to a web server, enter the destination URL.
●     To send the form data to an email address, enter mailto: followed by the email 

address. For example, mailto:nobody@adobe.com. 
6.  Select an Export Format option:
●     FDF exports as an FDF file. You can choose to export the form fields data, comments, 

incremental changes to the PDF file, or all three. The Incremental Changes To The PDF 
option is useful for exporting a digital signature in a way that is easily read and 
reconstructed by a server.

Note: If the server returns data to the user in FDF, or XFDF formats, the server's URL 
must end with the #FDF suffix; for example, http://myserver/cgi-bin/myscript#FDF.

●     HTML exports as an HTML file. 
●     XFDF exports as an XML file. You can choose to export the form fields data, comments, 

or both. 
●     PDF exports the entire PDF file that is your form. Although this creates a larger file than 

the FDF option, it is useful for preserving digital signatures.

Note: If the users that fill in the PDF form are using Adobe Reader, you must choose 
either FDF or XFDF for the Export Format option.

7.  For Field Selection, do one of the following:
●     To export all form fields even if the form fields do not contain values, select All Fields.
●     To export only specific form fields, select Only These. Click Select Fields, and then 

indicate the form fields to include, and whether you want to include empty fields.
8.  Select Convert Dates To Standard Format to export all form dates in a single format, no 

matter how they are entered in the form.
9.  Click OK to accept the selections.

10.  Click another tab in the Button Properties dialog box to continue defining properties for 
the button, or click Close.



 

Creating Reset Form buttons

Use the Reset A Form action to create a button that allows users to clear any form data 
already entered.

To create a Reset Form button:

1.  On the Forms toolbar, select the Button tool, and create a button. (See Creating interactive 
buttons.)

2.  Double-click the button to open the Button Properties dialog box.
3.  Click the Actions tab, and select Mouse Up from the Select Trigger menu.
4.  Select Reset A Form from the Select Action menu, and then click Add.
5.  In the Reset A Form dialog box, do one of the following, and then click OK:
●     To select individual fields, select the fields from the list.
●     To select all the fields, click Select All.
6.  Click another tab in the Button Properties dialog box to continue defining properties for 

the button, or click Close.



 

Creating Import Data buttons

You can use the Import Form Data action to enable users to fill out common form fields, 
such as name and email address, with data imported from another form. Users can also use 
the Import Data button to populate common form fields with their personal profile 
information. Only form fields that match are updated. Those that do not match are 
ignored. Before you create an Import Form Data action, you must have set up a form with 
common information form fields from which the data will be exported. (See Creating a 
spreadsheet from form data.) 

Note: The Import Form Data action searches for the data file from which to import data in 
different locations in Windows than on Mac OS. In Windows, the Import Form Data 
action searches the Acrobat or Acrobat Reader folder, the current folder, the System 
folder, the Windows folder, My Documents/Adobe/Acrobat, and the folders that are in the 
PATH statement. On Mac OS, the Import Form Data action searches the Acrobat or 
Acrobat Reader folder and the System Preferences folder.

To create an Import Data button: 

1.  On the Forms toolbar, select the Button tool, and create a button. (See Creating interactive 
buttons.)

2.  Double-click the button to open the Button Properties dialog box.
3.  Click the Actions tab, and select Mouse Up from the Select Trigger menu.
4.  Select Import Form Data from the Select Action menu, and then click Add.
5.  Locate and select an FDF file, and click Select.
6.  Click OK to accept the selections.
7.  Click another tab in the Button Properties dialog box to continue defining properties for 

the button, or click Close.



 

Defining CGI export values

An export value is the information sent to a CGI application to identify a user-selected 
form field. You need to define an export value only if both of the following are true:

●     The data is collected electronically in a database over a company intranet or the web.
●     The data is different from the item designated by the form field, or the form field is a radio 

button.

When defining export values, keep the following guidelines in mind:

●     Use the default export value Yes to indicate that a check box or radio button has been 
selected. 

●     Enter an export value for combo boxes or list boxes only if you want the value to be 
different from the item listed--for example, to match the name of the form field in a 
database. The item selected in the combo box or list box is used as the export value unless 
a different export value is explicitly entered in the Properties dialog box. 

●     Related radio buttons must have exactly the same form field name but different export 
values. This ensures that the radio buttons toggle and that the correct values will be 
collected in the database. 



 

Using custom JavaScripts in forms

The JavaScript language lets you create interactive web pages. Adobe has enhanced Java-
Script so that you can easily integrate interactivity into your PDF forms. The most 
common uses for JavaScript in Acrobat Professional forms are formatting, calculating, 
validating data, and assigning an action. You also configure Adobe PDF forms to connect 
directly to databases using ODBC (Windows only). To access the Acrobat JavaScript 
Scripting Reference, go to http://partners.adobe.com/links/acrobat (English only) on the 
Adobe website.

Note: If you are creating dynamic forms, keep in mind that Adobe Reader does not 
support some custom JavaScripts, so the form may not function properly when viewed in 
Adobe Reader unless additional usage rights were added to the PDF document. (See If 
you want to create documents that extend features to Adobe Reader users.)

For information on customizing Acrobat, see the Acrobat Software Development Kit 
(SDK). The Acrobat SDK is provided to members of the Adobe Solutions Network (ASN) 
Developer Program. For information on joining, requesting developer technical support, 
or obtaining updates to this SDK, refer to the Developer Support section of the Adobe 
website.
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About completing Adobe PDF forms

Adobe PDF forms can be static or interactive. Static PDF forms must be printed in order 
to be filled in, while interactive PDF forms contain form fields you can fill in on-screen. A 
PDF form is made interactive if its creator sets up the document with appropriate form 
fields and properties in Adobe Designer, Adobe Acrobat Professional, Acrobat Content 

Server, or even Adobe® GoLive® CS.

You can print a PDF form or export the form data to a separate file. Exporting form data 
allows you to save the existing data, or to transport it with an alternative method such as 
email. If you are filling out a PDF form from inside a web browser, you may be able to 
submit the form through the web.

When you search for words in a PDF document, the text in form fields is also 
searched by default. (See Searching for words in an Adobe PDF document.)
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Completing Adobe PDF forms

If a PDF form contains interactive form fields, you can fill in the form with the Basic 
toolbar's Hand tool. When you place the Hand tool pointer over an interactive form field, 

the pointer icon changes from the Hand icon  to the Pointing Hand icon , the 

Pointing Hand Plus icon , the Arrow icon , or the I-beam icon . If the form fields 

aren't interactive, the Hand icon  doesn't change; instead, you can print a noninteractive 
PDF form and fill it out by hand.

Some text fields are dynamic, which means they automatically resize to 
accommodate the amount of data you enter, and can span across pages. (See About form 
fields that span multiple pages and About typing in forms with barcodes.)

To fill out an interactive PDF form:

1.  Select the Hand tool .
2.  If you want to make form fields easier to identify in the PDF file, do any of the following 

in the Document Message Bar:
●     To display a light blue color in the background of all form fields, select Highlight Fields.
●     To display a red outline around all form fields that you're required to fill, select Highlight 

Required Fields. (This option appears only if the PDF form contains required fields.)
3.  Position the pointer inside a form field, and click. The I-beam pointer allows you to type 

text; the Arrow icon  lets you select an item in a list box; the Pointing Finger icon  or 

the Pointing Hand Plus icon  lets you select a button, a check box, a radio button, or an 
item from a list.

4.  After entering text or making a selection, do any of the following:
●     Press Tab or Shift+Tab to accept the form field change and go to the next or previous field.
●     Press Enter (Windows) or Return (Mac OS) to accept the text form field change and 

deselect the current field. If the current field is a check box, pressing Enter or Return turns 
the check box on or off. In a multiline text form field, pressing Enter or Return creates a 
paragraph return in the same form field. You can use Enter on the keypad to accept the 
change.

●     Press the Up or Left arrow key to select the previous radio button in a group of radio 
buttons, or press the Down or Right arrow key to select the next radio button.

●     Press Esc to reject the form field change and deselect the current form field. If you are in 
Full Screen mode, pressing Esc a second time causes you to exit Full Screen mode.

5.  Once you have filled in the appropriate form fields, do one of the following:
●     Click the submit form button, if one exists. Clicking this button sends the form data to a 

database across the web or over your company intranet.
●     Choose File > Save As, and rename the file to save the form with the data you entered.
●     Export the form data. (See Exporting form data.)
●     Print the form. (See Printing Adobe PDF documents.)

For information about how to fill in a digital signature form field, see Signing Adobe PDF 
documents.

To clear a form in a browser:

Do one of the following:

●     Select the reset form button, if one exists. You cannot undo this action.
●     Quit the browser, and start again.

Clicking the web browser's Reload or Refresh button or the Go Back button, or following 
a link in a browser window, may not clear a form.

To clear unsaved form entries in Acrobat:

Choose File > Revert.

Related Subtopics:

Completing fields automatically
About form fields that span multiple pages
About typing in forms with barcodes
Spell-checking text in forms
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Completing fields automatically

You can use the Auto-Complete Forms preferences to save time when filling in forms. If 
the first few characters you type in a form field match something you've typed in a 
previous form field, the Auto-Complete feature either displays a list of the most probable 
matches or automatically enters a very probable match for you.

To set Auto-Complete preferences:

1.  Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS), and select 
Forms from the list on the left.

2.  Choose an option from the Auto-complete menu. When you choose an option, the box 
below the option describes the effect of the selected option.

3.  If you want to include numerical characters in the auto-complete memory, select 
Remember Numerical Data.

To delete one or more Auto-Complete entries from storage:

1.  Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS), and select 
Forms from the list on the left.

2.  Click Edit Entry List.
3.  In the Auto-Complete Entry List dialog box, do one of the following, and click Yes in the 

confirmation dialog box:
●     To remove all of the entries, click Remove All.
●     To remove only some of the entries, select the entries and click Remove. Shift-click to 

select multiple adjacent entries; Ctrl-click (Windows) or Command-click (Mac OS) to 
select multiple nonadjacent entries.



 

About form fields that span multiple pages

Dynamic PDF forms can contain a dynamic text field that grows in size to accommodate 
the data you've entered into it; if necessary, the field may span onto the next page. A scroll 
bar appears in dynamic text fields when the data you enter exceeds the current size of the 
field; when you're finished entering data and the field is deactivated, the text field expands 
to display all of the entered data. If you want to continue editing a dynamic text field that 
spans across more than one page, you can begin editing the field on either page; you'll 
have access to all of the text in the box, no matter which page the text appears on.

Entering text in a form field that spans across two pages



 

About typing in forms with barcodes

PDF forms can contain barcode form fields that the creator of the PDF document added 
for various identification purposes, such as for an inventory of products. Barcode fields 
are either static or interactive. Interactive barcode fields that are created in Adobe 
Designer automatically encode the data that's entered into the form fields. The process of 
filling in an interactive PDF form that contains a static or interactive barcode is no 
different from filling in any other interactive PDF form. For information about capturing 
barcode form data, see the Adobe Barcoded Paper Forms Solution at www.adobe.com/
products/server/main.html.

Static barcode (left) and interactive barcode (right) created in Adobe Designer

Using Adobe Designer, you can create static barcode form fields that can be printed 
on any printer or barcode form fields that require a particular printer. 



 

Spell-checking text in forms

You can spell-check the text you typed in note comments and form fields. However, you 
cannot check the spelling of text in the underlying Adobe PDF document. (To do that, use 
the source application to spell-check the document before you create the PDF document.) 
Unrecognized words appear underlined after you type them. You can edit these words in 
context, or you can open the Check Spelling dialog box.

To change a single misspelled word:

Right-click (Windows) or Control-click (Mac OS) the word in the form field or comment 
pop-up window, and then choose the correct word from the list of alternatives.

To spell-check text in comments and forms:

1.  Choose Edit > Check Spelling > In Comments And Form Fields. If the PDF document is 
open in a web browser, make sure that the Edit toolbar is open, and click the Spell Check 

button .
2.  Click Start to begin the spell check. When a word that may be misspelled is found, it 

appears under Word Not Found. Suggested corrections appear under Suggestions. After 
you do one of the options in step 3, the next unrecognized word (if any) is highlighted; 
then you should repeat step 3 until the Restart button appears.

3.  Do one of the following: 
●     Edit the selected word. To undo your change, click Undo Edit. To accept your change, 

click Change.
●     Double-click to select a correction from the list of suggestions.
●     Click Ignore if you don't want to change the word, and want to continue with the check.
●     Click Ignore All to ignore every instance of the word. Click Add if you want to add the 

word to your personal dictionary. 
●     Click Change to replace the unrecognized word with the one in the Suggested Corrections 

section. Click Change All to replace every instance of the unrecognized word with the one 
in the list of suggestions.

4.  Click Done when you are finished with the spell check.

To specify a language dictionary:

1.  Choose Edit > Check Spelling > Edit Dictionary.
2.  Choose the language dictionary you want to use from the Dictionary menu, and then click 

Done.



 

Importing form data

In addition to filling out a PDF form manually, you can import file data from a text 
(TXT), Extensible Markup Language (XML), Acrobat Form Data Format (FDF), XML 
Data Package File (XDP), FormFlow99 Data Files (XFD), or Acrobat XFDF (XFDF) file 
into a PDF form. Some file formats are available only when you're importing the data into 
particular PDF forms, such as a PDF form created in Adobe Designer.

Note: If you're importing file data from a text file, each row in a text file must be tab-
delimited to create columns, as in a table. When a row of data is imported, each cell 
becomes the value of the form field that corresponds to the column name.

To import form data from a file:

1.  Open the Adobe PDF form.
2.  Choose File > Form Data > Import Data To Form.
3.  Choose the form data type from the Files Of Type menu, select a file, and click Select.

Note: If you import form data from a form that does not match the form you are importing 
into, only the form fields that match are updated, and those that do not match are ignored. 
Existing text in text form fields is replaced if you import data to those fields.



 

Exporting form data

You can export the data you've entered into a form to a separate file. Exporting form data 
lets you save existing data to a file that's considerably smaller than the original PDF file. 
A smaller file is preferable for archiving or sharing the data electronically. You can save 
the form data as a tab-separated text (TXT), Acrobat XFDF (XFDF), Acrobat Form Data 
Format (FDF), or Extensible Markup Language (XML) file. Some of these file formats are 
available only when you're exporting the data from particular PDF forms, such as a PDF 
form created in Adobe Designer.

You can also import data from an exported file into another form if that form has fields 
with the same names. Alternatively, you can import file data from a text file. (See 
Importing form data.)

To export form data to a file:

1.  Open the Adobe PDF form and fill it out.
2.  Choose File > Form Data > Export Data From Form.
3.  Choose a format type from the Save As Type menu, specify a location and file name, and 

then click Save.



 

Emailing completed forms

PDF forms can contain an email-based submit button that exports the information that you 
entered into the PDF form, which you must then email with your own email application. 
You have the option to email the PDF with a desktop or web-based email application, or 
you can submit the form data at a later time. 

Note: If the PDF form doesn't contain an email-based submit button, it may have a submit 
button that sends the form data via the web or some other service.

To submit an email-based PDF form:

1.  After you've filled in the PDF form, click the submit button on the PDF form.
2.  In the Select Email Client dialog box, select the option that best describes how you send 

email, and then click OK:
●     Desktop Email Application, such as Microsoft Outlook or Eudora. For next steps, see 

Submitting PDF forms with a desktop email application.
●     Internet Email for web browser-based services, such as Microsoft Hotmail or Yahoo mail. 

For next steps, see Submitting PDF forms with a web-based email service.
●     Other if your email application or service isn't available or you don't know which option 

to choose. For next steps, see Submitting a PDF form at a different time.

Related Subtopics:

Submitting PDF forms with a desktop email application
Submitting PDF forms with a web-based email service
Submitting a PDF form at a different time



 

Submitting PDF forms with a desktop email application

When you click an email-based submit button in a PDF form, you have the option to 
submit the form data with your preferred desktop email application.

To submit a PDF form with a desktop email application:

1.  After you've filled in the PDF form, click the submit or return form button on the PDF 
form.

2.  In the Select Email Client dialog box, select Desktop Email Application; then click OK. 
3.  In the Send Data File dialog box, click Print Form if you want a copy of the filled-in form; 

then click Send Data File. 

Your default email application displays a new email message with the To, Subject, Body, 
and Attachment fields automatically filled in. 

4.  Use your email application to send the email.
5.  Click Close in the Email Confirmation dialog box in Acrobat.



 

Submitting PDF forms with a web-based email service

When you click an email-based submit button in a PDF form, you have the option to 
submit the form data with a web-based email service.

To submit a PDF form with a web-based email service:

1.  Click the submit or return form button on the PDF form. If the form fields are blank, the 
Email A Blank Copy Of This Form dialog box appears; click Email A Blank Copy.

2.  In the Select Email Client dialog box, select Internet Email; then click OK. 
3.  In the Sending The Data File dialog box, click Save Data File. 
4.  In the Save Data File dialog box, choose a location on your computer to save the file; then 

click Save. 
5.  Open a new browser window, log in to your web-based email service, and use your 

service to create a new blank email. 
6.  In the Sending the Data File dialog box in Acrobat, select the value in the To field; then 

right-click (Windows) or Control-click (Mac OS) and choose Copy. 
7.  In your blank email message in your Internet email service, click in the To field, and paste 

the data you copied. Repeat steps 6 and 7 for the Subject and Message Text fields.
8.  Use your Internet email service to attach the data file (that you saved in step 4) to your 

email message. 
9.  If you want a copy of the filled-in form, click Print Form in the Sending The Data File 

dialog box in Acrobat.
10.  Click Close in the Sending The Data File dialog box.



 

Submitting a PDF form at a different time

When you click an email-based submit button in a PDF form, you have the option to not 
submit the form data and instead to save the form data on your computer to send at a 
different time.

To submit a PDF form at a different time:

1.  Click the Submit or Return Form button on the PDF form. If the form fields are blank, the 
Email A Blank Copy Of This Form dialog box appears; click Email A Blank Copy. 

2.  In the Select Email Client dialog box, select Other, and then click OK.
3.  In the Sending The Data File dialog box, click Save Data File. 
4.  In the Save Data File dialog box, choose a location on your computer to save the file; then 

click Save. 
5.  Write down the values that appear in the To, Subject, and Message Text fields so you can 

use them later when you want to email the form data. 
6.  If you want a copy of the filled-in form, click Print Form in the Sending The Data File 

dialog box in Acrobat.
7.  Click Close in the Sending The Data File dialog box. 
8.  When you want to submit the PDF form, create a new email message in your email 

application. Enter the To, Subject, and Message Text values that you wrote down in step 
5. Use your email application to attach the data file that you saved in step 4; then send the 
email.



 

Collecting form data by email

After you've created a PDF form that contains form fields and an email-based submit 
button, you can use the Initiate Form Data Collection Workflow command to quickly 
distribute the form to others via email. Once a form recipient has filled in the PDF form, 
they're automatically guided step-by-step to ensure that their form data is returned to the 
email address specified by the email-based submit button. (To create an email-based 
submit button, see Creating Acrobat submit buttons.)

After you've received multiple sets of form data for a particular PDF form that 
you've distributed, you can organize the form data into a spreadsheet file. (See Creating a 
spreadsheet from form data.)

To collect form data by email:

1.  Open a PDF file that contains form fields and an email-based submit button. 
2.  Do one of the following to display the Initiate Data File Collection Workflow dialog box:

●     Choose Initiate Form Data Collection Workflow from the Form Tasks menu  in the 
Tasks toolbar.

●     Choose Advanced > Forms > Initiate Form Data Collection Workflow.
●     Choose File > Form Data > Initiate Form Data Collection Workflow.
3.  Do one of the following, according to the dialog box that appears:
●     Click Next if the Initiate Form Data Collection Workflow dialog box appears.
●     Click Close if the Form Fields And Email Submit Button Required dialog box appears. 

You must add form fields and an email-based submit button to your PDF file before you 
can use the form data collection workflow. (See Creating forms from scratch.)

●     Click Close if the Email Submit Button Required dialog box appears. You must add an 
email-based submit button that was created in Designer or Acrobat Professional to your 
PDF form file before you can use the form data collection workflow. (See Creating 
Acrobat submit buttons.)

4.  Type the email address of each person you want to receive the PDF form in the Invite 
Recipients box, and type a comma between email addresses.

5.  If you want to edit the message that the form recipients receive, edit the text in the 
Preview Invitation box.

6.  Click Send Invitation.

Related Subtopics:

Creating a spreadsheet from form data



 

Creating a spreadsheet from form data 

Once you've collected PDF form data in FDF or XML format from multiple users, you 
can organize the form data into a comma-delimited spreadsheet file (CSV). After 
exporting the form data to a CSV file, you can work with the data in a spreadsheet 
application, such as Microsoft Excel.

Create a folder on your computer to contain the form data that you receive via 
email; then, when you organize that data into a spreadsheet or need to review individual 
responses, you can quickly locate all of the files.

To organize form data into a spreadsheet:

1.  Choose File > Form Data > Create Spreadsheet From Data Files.
2.  If you want to automatically include all forms and form data that you've previously added 

to the Data Files list, select Include Most Recent List Of Files To Export Data From.
3.  Click Add Files, select one or more files that have an .xml, .fdf, .pdf, or .xfdf file name 

extension, and then click Select. Repeat this step if you want to add more files to the list.
4.  If you want to remove a file from the list, select the file, and click Remove Files.
5.  Click Create Spreadsheet.
6.  Select a location on your computer to save the spreadsheet, and then click Save. The 

Create Spreadsheet dialog box displays "Done" when Acrobat has created the spreadsheet. 
7.  If you want to open the spreadsheet file in your default spreadsheet application, click 

View File Now; otherwise, click Close The Dialog.




